WIN XP - keine Internetverbindung über Explorer



  • @GuidoB
    Tips von Andre2:
    http://dsl-webseiten.de/forum/showthread.php?s=&postid=8772#post8772

    @tobiflyer
    gibt (fast) keine blöden Fragen - nur dumme Antworten,
    Info kommt gleich!



  • danke Firewall 🙂

    Also Guido, ich konnte ww.t-online.de mit bis zu 1420 byte anpingen. Ab 1430 wollte er nimmer. Gruß Tobi



  • Übernommen von Andre2:
    –---
    Doch, entdeckt: nach Aufruf des Webkonfigurators über 192.168.2.1 unter "ADSL über PPoE" den Wert ändern.

    gruss andre2

    thanx to Andre2!



  • sorry, mach 1410 byte draus!



  • Thanks Firewall ich teste das mal mit 1410 abzüglich 40 byte = 1370, richtig??



  • Also: Konnte die MTU auf ein Minimum von 1440 setzen. drunter ging nicht. Aber I Explorer auf dem Lapi will noch nich'



  • Hallo,

    ping Datenpaket - Grösse + 28 Bytes = MTU-Size

    Also plus, nicht minus!

    Siehe:
    http://www.dsl-webseiten.de/forum/showthread.php?s=&threadid=1344&highlight=MTUSize

    Standard wäre:
    Daten (aus Ping) = 1472 Bytes +
    IP-Header = 20 Bytes +
    UDP-Header = 8 Bytes

    MTU-Size = 1500 = Ethernet Standard

    Jetzt rechne das mit Deinen Werten nach und stelle ein …



  • Also Max Ping hat sich jetzt 1412 ergeben. Hierzu 28 dazu und dann kommen wir auf 1440, das stell ich mal ein, sekunde



  • So habs im Router eingestellt. Ist übrigens der minimalste Wert den ich wählen kann. Muß man die Pc's dann neu booten?

    Gruß
    Tobi



  • jetzt bleibt noch die Frage mit der registry…
    So langsam fängt es an Spaß zu machen mit so einer Profi Hilfe. Dank' euch Jungs 🙂



  • yep,
    neu booten!

    Aber erst, wenn wir die Registry geändert haben!



  • Hallo,

    @tobiflyer
    Musst Dich etwas gedulden, weil ich gerade kein XP laufen habe (nur 2000 Server) und deshalb habe ich Kollegen hier gefragt …
    Ist zu gefährlich in der Registry "rumzufummeln" ohne es direkt nachzuvollziehen.

    Also Geduld ...



  • Kein Thema, lass Dir Zeit. Vertrau Dir da voll und ganz 😉



  • Ich lese das hier gerade …

    http://support.microsoft.com/default.aspx?scid=kb;en-us;283165

    Mal schauen …



  • Ok, der Artikel oben ist nur für das PPPoE Protokoll, trifft aber auf Deine Sache nicht zu, weil wir ja einen Router haben, der das PPPoE macht, den Wert hast Du ja schon eingestellt.

    Frage:
    Damit wir sicher sind, poste noch mal genau diesen Wert, auf dem der Router jetzt steht!

    In der Zwischenzeit wühle ich mich hier durch:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;314053

    Bis gleich …



  • Router MTU ist momentan auf 1440

    Gruß Tobi 🙂



  • Hallo,

    Auszug aus dem Artikel:

    TCP/IP and NBT Configuration Parameters for Windows XP
    –---------------------------------------------------------------------------

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet
    \Services

    Tcpip\Parameters
    Tcpip\Parameters\Interfaces\ID for Adapter

    EnablePMTUDiscovery
    Key: Tcpip\Parameters
    Value Type: REG_DWORD - Boolean
    Valid Range: 0,1 (False, True)
    Default: 1 (True)
    Description: Setting this parameter to 1 (True) causes TCP to attempt to discover the Maximum Transmission Unit (MTU or largest packet size) over the path to a remote host. By discovering the Path MTU and limiting TCP segments to this size, TCP can eliminate fragmentation at routers along the path that connect networks with different MTUs. Fragmentation adversely affects TCP throughput and network congestion. Setting this parameter to 0 causes an MTU of 576 bytes to be used for all connections that are not to computers on the local subnet.

    MTU
    Key: Tcpip\Parameters\Interfaces\ID for Adapter
    Value Type: REG_DWORD Number
    Valid Range: 68 - the MTU of the underlying network
    Default: 0xFFFFFFFF
    Description: This parameter overrides the default Maximum Transmission Unit (MTU) for a network interface. The MTU is the maximum packet size in bytes that the transport will transmit over the underlying network. The size includes the transport header. Note that an IP datagram can span multiple packets. Values larger than the default for the underlying network will result in the transport's using the network default MTU. Values smaller than 68 will result in the tranport's using an MTU of 68.
    –---------------------------------------------------------------------------

    Bin gleich wieder da ... muss das zusammenstellen und prüfen.



  • Hallo,

    ich zitiere zunächst einen Kollegen hier aus dem Forum.

    Andre2 sagte mir (Danke an dieser Stelle an Andre2😞

    etwas, was mir noch kaum jemand glauben wollte: in meinem XP gibt es keinen Registry-Key für die MTU….
    Hab die Registry durchsucht, kommt nix, auch nicht unter TCP/IP Parameters oder der MAC der Netzwerkkarte.
    Hab natürlich die Suchfunktion in der Registry benutzt.
    Allerdings: das Herabsetzen der MTU im Router reicht imho völlig aus. Jedenfalls hat das bei allen Eumex-Usern gereicht, um eine stabile Verbindung ins Inet zu bekommen.

    Wenn man noch das, was Microsoft dazu sagt (s.o), hinzu nimmt,
    kommen wir zu folgendem Ergebnis:

    EnablePMTUDiscovery
    Key: Tcpip\Parameters
    Value Type: REG_DWORD - Boolean
    Valid Range: 0,1 (False, True)
    Default: 1 (True)

    Deshalb brauchen wir in der Registry nichts, aber auch gar nichts verstellen, weil XP automatisch den besten Wert für die MTU-Grösse ermittelt und einstellt.

    Boote deshalb zur Sicherheit nur die Rechner neu, teste und gebe Bescheid.



  • Hallo,

    tut mir ja Leid das sagen zu müssen, aber es geht leider auch nach neu booten wieder nicht. Ich verstehe das nicht. Ich kann in der wwWeltgeschichte rumpingen aber keine Site öffnen. Das gibts doch fast gar nicht.

    Gruß Tobi



  • Hallo,

    und Kazaa ist immer noch aus?


Log in to reply